IdP groups stopped working for printer deployment/portal security

Incident Report for Vasion

Postmortem

IdP groups stopped working for printer deployment/portal security

Issue Summary:

On 14 May 2025, at approximately 1:30 PM (MDT), the Vasion Print platform experienced a service disruption for printer deployment when using an Identity Provider (IdP) group.

Root Cause: 

A data query was updated to pull data from a mirrored dataset. The mirrored dataset had not fully synced all of the original data.

Resolution: 

All customers reporting the issue have been addressed by Vasion’s software and data engineers working to identify the missing data and running a sync of the original data into the proper mirrored dataset.

Mitigation:

Updates have been made to the mirroring process to ensure all data is properly synced in the future. 

Conclusion:

No data has been lost during this incident. The underlying issue was due to data not fully syncing between two datasets. Each tenant for which the occurrence had been reported has been resolved. The underlying process has been updated to prevent further recurrence.

Posted May 16, 2025 - 16:45 UTC

Resolved

This incident has been resolved.
Posted May 15, 2025 - 12:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 02:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2025 - 01:47 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 22:56 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 20:26 UTC
This incident affected: Scheduled Release - US Region (User Authentication).